// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((concorde|immo )?invest\b(\sconseil)?|investi(e?s)?$|sans invest.+)").unwrap();
let string = "NE PAS PRENDRE EN COMPTE
concorde invest
invest conseil
pro immo invest
avons investi
très investies
nous sommes investis
sans investissement suplémentaire
pattern = ((concorde|immo )?invest\\b(\\sconseil)?|investi(e?s)?$|sans invest.+)
---------------------------------------------------------------
pattern = (investi[a-z]+|invest )
idéal invest
ideal premier investissement
ideal occupant et investisseur
idéal pour investir
projet pour investisseurs
pour faire un investissement
idéal pour investissement
local pour investissement
local commercial pour investisseur
parfait pour des investisseurs
idéal investisseur
idéal pour utilisateur ou investisseur
idéal profession libérale ou investisseur
s’adressant à des investisseurs
dédié à l'investissement
vente destinée à investisseurs
a vendre investissement
à vendre dans le cadre d'un investissement
des activités comme investisseur
bel investissement
excellent investissement
opportunité investisseur
opportunité d'implantation ou d'investissement
opportunité pour investir
opportunité à l'investissement
exclusivité investisseur
exclusivité vente a investisseur
spécial investisseurs
rentabilité pour investissement
investissement à forte rentabilité
produit investissement
rentabilité 8% pour investisseurs
investissement sans risque
investir en toute sécurité
investissement idéal
soyez les premiers à investir
disponible à la vente en investissement
vente de murs occupés à investisseur
investir sur ces murs libres
propose à la l'investissement
conviendrait à un investisseur
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}