#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((concorde|immo )?invest\b(\sconseil)?|investi(e?s)?$|sans invest.+)"
Local $sString = "NE PAS PRENDRE EN COMPTE" & @CRLF & _
"concorde invest" & @CRLF & _
"invest conseil" & @CRLF & _
"pro immo invest" & @CRLF & _
"avons investi" & @CRLF & _
"très investies" & @CRLF & _
"nous sommes investis" & @CRLF & _
"sans investissement suplémentaire" & @CRLF & _
"" & @CRLF & _
"pattern = ((concorde|immo )?invest\b(\sconseil)?|investi(e?s)?$|sans invest.+)" & @CRLF & _
"---------------------------------------------------------------" & @CRLF & _
"pattern = (investi[a-z]+|invest )" & @CRLF & _
"" & @CRLF & _
"idéal invest" & @CRLF & _
"ideal premier investissement" & @CRLF & _
"ideal occupant et investisseur" & @CRLF & _
"idéal pour investir" & @CRLF & _
"projet pour investisseurs" & @CRLF & _
"pour faire un investissement" & @CRLF & _
"idéal pour investissement" & @CRLF & _
"local pour investissement" & @CRLF & _
"local commercial pour investisseur" & @CRLF & _
"parfait pour des investisseurs" & @CRLF & _
"idéal investisseur" & @CRLF & _
"idéal pour utilisateur ou investisseur" & @CRLF & _
"idéal profession libérale ou investisseur" & @CRLF & _
"" & @CRLF & _
"s’adressant à des investisseurs" & @CRLF & _
"dédié à l'investissement" & @CRLF & _
"vente destinée à investisseurs" & @CRLF & _
"a vendre investissement" & @CRLF & _
"à vendre dans le cadre d'un investissement" & @CRLF & _
"" & @CRLF & _
"des activités comme investisseur" & @CRLF & _
"" & @CRLF & _
"bel investissement" & @CRLF & _
"excellent investissement" & @CRLF & _
"" & @CRLF & _
"opportunité investisseur" & @CRLF & _
"opportunité d'implantation ou d'investissement" & @CRLF & _
"opportunité pour investir" & @CRLF & _
"opportunité à l'investissement" & @CRLF & _
"" & @CRLF & _
"exclusivité investisseur" & @CRLF & _
"exclusivité vente a investisseur" & @CRLF & _
"spécial investisseurs" & @CRLF & _
"" & @CRLF & _
"rentabilité pour investissement" & @CRLF & _
"investissement à forte rentabilité" & @CRLF & _
"produit investissement" & @CRLF & _
"" & @CRLF & _
"rentabilité 8% pour investisseurs" & @CRLF & _
"investissement sans risque" & @CRLF & _
"investir en toute sécurité" & @CRLF & _
"" & @CRLF & _
"investissement idéal" & @CRLF & _
"" & @CRLF & _
"soyez les premiers à investir" & @CRLF & _
"" & @CRLF & _
"disponible à la vente en investissement" & @CRLF & _
"vente de murs occupés à investisseur" & @CRLF & _
"" & @CRLF & _
"investir sur ces murs libres" & @CRLF & _
"" & @CRLF & _
"propose à la l'investissement" & @CRLF & _
"" & @CRLF & _
"conviendrait à un investisseur" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")