$re = '/I am a (student|Engineer)/m';
$str = 'I am a Engineer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);