package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I am a (student|Engineer)`)
var str = `I am a Engineer`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}