re = /.?(\*\!)(\w*){1,}/m
str = '*!adsfasdf
* !adsfasdf
*
*!
*!
* asfsadf
*asdfsadf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end