package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).?(\*\!)(\w*){1,}`)
var str = `*!adsfasdf
* !adsfasdf
*
*!
*!
* asfsadf
*asdfsadf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}