import Foundation
let pattern = #"(@Column *\( *name *= *"(.+?)".+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@Column(name = "UTL_DA_PRTCPZN_IC", table = "ALL_PRQZN_SEZ_PRNCPL")
private Importo utiliDaPartecipazioneIC;
@Column(name = "UTL_DA_PRTCPZN_IFD", table = "ALL_PRQZN_SEZ_PRNCPL")
private Importo utiliDaPartecipazioneIFD;
@Column(name = "PRQZN_RDZN_PRTCPZN_UTL_ALQ_IC", table = "ALL_PRQZN_SEZ_PRNCPL")
private Aliquota riduzionePartecipazioniAliquotaIC;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n\t@BeanStructProperty(uniqueName = "$2")"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)