import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@Column *\\( *name *= *\"(.+?)\".+)";
final String string = " @Column(name = \"UTL_DA_PRTCPZN_IC\", table = \"ALL_PRQZN_SEZ_PRNCPL\")\n"
+ " private Importo utiliDaPartecipazioneIC;\n\n"
+ " @Column(name = \"UTL_DA_PRTCPZN_IFD\", table = \"ALL_PRQZN_SEZ_PRNCPL\")\n"
+ " private Importo utiliDaPartecipazioneIFD;\n\n"
+ " @Column(name = \"PRQZN_RDZN_PRTCPZN_UTL_ALQ_IC\", table = \"ALL_PRQZN_SEZ_PRNCPL\")\n"
+ " private Aliquota riduzionePartecipazioniAliquotaIC;";
final String subst = "$1\\n\\t@BeanStructProperty(uniqueName = \"$2\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}