$re = '/([A-Z_]*)_(UGEL[A-Z_0-9]*).pdf/';
$str = 'LIMA_METROPOLITANA_UGEL_05_SAN_JUAN_DE_LURIGANCHO.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);