package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z_]*)_(UGEL[A-Z_0-9]*).pdf`)
var str = `LIMA_METROPOLITANA_UGEL_05_SAN_JUAN_DE_LURIGANCHO.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}