const regex = new RegExp('[\\(\\)()]', 'g')
const str = `abcdwadwadadaabc()dwadwadwad()()`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);