package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\([^\(]*\))`)
var str = `( rafa / %aa)+(23+34)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}