#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\([^\(]*\))"
Local $sString = "( rafa / %aa)+(23+34)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)