$re = '/^[A-Z-0-9]{1,15}$/';
$str = '1A23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);