package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Z-0-9]{1,15}$`)
var str = `1A23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}