# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d: ([\w@]+): <(.+)> mtu (\d+) qdisc (\w+) qlen (\d+)\n[ ]+(\w+\/\w+) ([\d:\w.]+) brd ([\d:\w.]+)\n?(?:(?: )+inet6? ([\d.:\/]+) (?:brd ([\d:\w.]+) )?scope (\w+) (?:\w+)?\n(?: )+valid_lft (\w+) preferred_lft (\w+))?"
test_str = ("1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1\n"
" link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00\n"
" inet 127.0.0.1/8 scope host lo\n"
" valid_lft forever preferred_lft forever\n"
" inet6 ::1/128 scope host \n"
" valid_lft forever preferred_lft forever\n"
"2: lan1: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc mq qlen 1000\n"
" link/ether 00:60:e0:6a:48:26 brd ff:ff:ff:ff:ff:ff\n"
" inet 10.32.39.55/24 brd 10.32.39.255 scope global lan1\n"
" valid_lft forever preferred_lft forever\n"
"3: lan2: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc mq qlen 1000\n"
" link/ether 00:60:e0:6a:48:27 brd ff:ff:ff:ff:ff:ff\n"
" inet 192.168.90.1/20 brd 192.168.95.255 scope global lan2\n"
" valid_lft forever preferred_lft forever\n"
"4: sit0@NONE: <NOARP> mtu 1480 qdisc noop qlen 1\n"
" link/sit 0.0.0.0 brd 0.0.0.0\n"
"6: wwp0s29u1u3i12: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000\n"
" link/ether 00:00:11:12:13:14 brd ff:ff:ff:ff:ff:ff\n"
" inet 172.16.224.124/16 brd 172.16.255.255 scope global wwp0s29u1u3i12\n"
" valid_lft forever preferred_lft forever\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.