#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d: ([\w@]+): <(.+)> mtu (\d+) qdisc (\w+) qlen (\d+)\n[ ]+(\w+\/\w+) ([\d:\w.]+) brd ([\d:\w.]+)\n?(?:(?: )+inet6? ([\d.:\/]+) (?:brd ([\d:\w.]+) )?scope (\w+) (?:\w+)?\n(?: )+valid_lft (\w+) preferred_lft (\w+))?"
Local $sString = "1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1" & @CRLF & _
" link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00" & @CRLF & _
" inet 127.0.0.1/8 scope host lo" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
" inet6 ::1/128 scope host " & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"2: lan1: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc mq qlen 1000" & @CRLF & _
" link/ether 00:60:e0:6a:48:26 brd ff:ff:ff:ff:ff:ff" & @CRLF & _
" inet 10.32.39.55/24 brd 10.32.39.255 scope global lan1" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"3: lan2: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc mq qlen 1000" & @CRLF & _
" link/ether 00:60:e0:6a:48:27 brd ff:ff:ff:ff:ff:ff" & @CRLF & _
" inet 192.168.90.1/20 brd 192.168.95.255 scope global lan2" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"4: sit0@NONE: <NOARP> mtu 1480 qdisc noop qlen 1" & @CRLF & _
" link/sit 0.0.0.0 brd 0.0.0.0" & @CRLF & _
"6: wwp0s29u1u3i12: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000" & @CRLF & _
" link/ether 00:00:11:12:13:14 brd ff:ff:ff:ff:ff:ff" & @CRLF & _
" inet 172.16.224.124/16 brd 172.16.255.255 scope global wwp0s29u1u3i12" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")