re = /(?<=[\.,;\s\t\n])[a-z0-9\-]{2,}(?=[\.,;\s\t\n])/m
str = ' -a- -a-ll- [Enter KING HENRY, LORD JOHN OF , -,the;, LANCASTER , , the EARL
!and =all =12 ,123-,;, -qw !all a-a -doof I -i ,9ab+
xxx xx x !all ?nicht !and -doof -12 -aa
of WESTMORELAND, SIR WALTER BLUNT, and others]
12 d12a ; a1 d1a, ! ,aaaaa aaa ,aa1 .1a , ; !.a12
KING HENRY IV So !shaken as we, the are, so wan with care,
Find we a time; for frighted peace to pant,
And breathe short-winded accents of new broils
To be commenced in strands afar remote.
No more the thirsty entrance of this soil
Shall 12 daub her 1l1ips with her own children\'s blood;
Nor more shall trenching war channel her fields,
Nor bruise her flowerets with the armed hoofs
Of hostile paces: those opposed eyes,
Which, like the meteors of a troubled heaven,
All of one nature, of one substance bred,
Did lately meet in the intestine shock
And furious close of civil butchery
Shall now, in mutual well-beseeming ranks,
March all one way and be no more opposed
Against acquaintance, kindred and allies:
The edge of war, like an ill-sheathed knife,
No more shall cut his master. Therefore, friends,
As far as to the sepulchre of Christ,
Whose soldier now, under whose blessed cross
We are impressed and engaged to fight,
Forthwith a power of English shall we levy;
Whose arms were moulded in their mothers\' womb
To chase these pagans in those holy fields
Over whose acres walk\'d those blessed feet
Which fourteen hundred years ago were nail\'d
For our advantage on the bitter cross.
But this our purpose now is twelve month old,
And bootless \'tis to tell you we will go:
Therefore we meet not now. Then let me hear
of you, my gentle cousin Westmoreland,
What yesternight our council did decree
In forwarding this dear expedience.
WESTMORELAND my liege, this haste was hot in question,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end