#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[\.,;\s\t\n])[a-z0-9\-]{2,}(?=[\.,;\s\t\n])"
Local $sString = " -a- -a-ll- [Enter KING HENRY, LORD JOHN OF , -,the;, LANCASTER , , the EARL" & @CRLF & _
"!and =all =12 ,123-,;, -qw !all a-a -doof I -i ,9ab+" & @CRLF & _
"xxx xx x !all ?nicht !and -doof -12 -aa" & @CRLF & _
" of WESTMORELAND, SIR WALTER BLUNT, and others]" & @CRLF & _
"12 d12a ; a1 d1a, ! ,aaaaa aaa ,aa1 .1a , ; !.a12" & @CRLF & _
"KING HENRY IV So !shaken as we, the are, so wan with care," & @CRLF & _
" Find we a time; for frighted peace to pant," & @CRLF & _
" And breathe short-winded accents of new broils" & @CRLF & _
" To be commenced in strands afar remote." & @CRLF & _
" No more the thirsty entrance of this soil" & @CRLF & _
" Shall 12 daub her 1l1ips with her own children's blood;" & @CRLF & _
" Nor more shall trenching war channel her fields," & @CRLF & _
" Nor bruise her flowerets with the armed hoofs" & @CRLF & _
" Of hostile paces: those opposed eyes," & @CRLF & _
" Which, like the meteors of a troubled heaven," & @CRLF & _
" All of one nature, of one substance bred," & @CRLF & _
" Did lately meet in the intestine shock" & @CRLF & _
" And furious close of civil butchery" & @CRLF & _
" Shall now, in mutual well-beseeming ranks," & @CRLF & _
" March all one way and be no more opposed" & @CRLF & _
" Against acquaintance, kindred and allies:" & @CRLF & _
" The edge of war, like an ill-sheathed knife," & @CRLF & _
" No more shall cut his master. Therefore, friends," & @CRLF & _
" As far as to the sepulchre of Christ," & @CRLF & _
" Whose soldier now, under whose blessed cross" & @CRLF & _
" We are impressed and engaged to fight," & @CRLF & _
" Forthwith a power of English shall we levy;" & @CRLF & _
" Whose arms were moulded in their mothers' womb" & @CRLF & _
" To chase these pagans in those holy fields" & @CRLF & _
" Over whose acres walk'd those blessed feet" & @CRLF & _
" Which fourteen hundred years ago were nail'd" & @CRLF & _
" For our advantage on the bitter cross." & @CRLF & _
" But this our purpose now is twelve month old," & @CRLF & _
" And bootless 'tis to tell you we will go:" & @CRLF & _
" Therefore we meet not now. Then let me hear" & @CRLF & _
" of you, my gentle cousin Westmoreland," & @CRLF & _
" What yesternight our council did decree" & @CRLF & _
" In forwarding this dear expedience." & @CRLF & _
"" & @CRLF & _
"WESTMORELAND my liege, this haste was hot in question," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")