re = /^((?:1[0-4]\d{2})|(?:\d{1,3}))(?:(?:lb)?$|(?:lb(1[0-5]|[1-9])(?:oz)?)$)/m
str = '1500'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end