const regex = /^((?:1[0-4]\d{2})|(?:\d{1,3}))(?:(?:lb)?$|(?:lb(1[0-5]|[1-9])(?:oz)?)$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:1[0-4]\\d{2})|(?:\\d{1,3}))(?:(?:lb)?$|(?:lb(1[0-5]|[1-9])(?:oz)?)$)', 'mg')
const str = `1500`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}