$re = '`[^@]{2,64}@[^.]{2,253}\.[0-9a-z-.]{2,63}`';
$str = 'name@anywhere.something';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);