package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^@]{2,64}@[^.]{2,253}\.[0-9a-z-.]{2,63}`)
var str = `name@anywhere.something`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}