import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[+]6)?0(([0-9]{2}((\\s[0-9]{3,4}\\s[0-9]{4})|(-[0-9]{3,4}\\s[0-9]{4})|(-[0-9]{7,8})))|([0-9]{9,10}))$";
final String string = "01234567890\n"
+ "+601234567890\n\n"
+ "012-34567890\n"
+ "+6012-34567890\n\n"
+ "012-3456 7890\n"
+ "+6012-3456 7890\n\n"
+ "012 3456 7890\n"
+ "+6012 3456 7890\n\n"
+ "#invalid:\n\n"
+ "0122 3456 7890\n"
+ "12 3456 7890\n"
+ "+60122 3456 7890\n"
+ "012345678900\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}