#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[+]6)?0(([0-9]{2}((\s[0-9]{3,4}\s[0-9]{4})|(-[0-9]{3,4}\s[0-9]{4})|(-[0-9]{7,8})))|([0-9]{9,10}))$"
Local $sString = "01234567890" & @CRLF & _
"+601234567890" & @CRLF & _
"" & @CRLF & _
"012-34567890" & @CRLF & _
"+6012-34567890" & @CRLF & _
"" & @CRLF & _
"012-3456 7890" & @CRLF & _
"+6012-3456 7890" & @CRLF & _
"" & @CRLF & _
"012 3456 7890" & @CRLF & _
"+6012 3456 7890" & @CRLF & _
"" & @CRLF & _
"#invalid:" & @CRLF & _
"" & @CRLF & _
"0122 3456 7890" & @CRLF & _
"12 3456 7890" & @CRLF & _
"+60122 3456 7890" & @CRLF & _
"012345678900" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")