const regex = / {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'"`]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' {2}|\\r\\n|&(?!(#\\d+|\\w+);)|[<>\\r\\n\'"`]', 'g')
const str = ` {2}|\\r\\n|[&(?!(#\\\\d+|\\\\w+);)<>\\r\\n'"\`]
&&& ' ; "< >
"http://www.example.com/?a=1&b=2&c=3/",
"Three in a row: &&&",
"< is <, > is >, ' is ', etc." handle numeric escapes, e.g.   – Jake Cobb Aug 3 '16 at 19:55 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}