using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" {2}|\r\n|&(?!(#\d+|\w+);)|[<>\r\n'""`]";
string input = @" {2}|\r\n|[&(?!(#\\d+|\\w+);)<>\r\n'""`]
&&& ' ; ""< >
""http://www.example.com/?a=1&b=2&c=3/"",
""Three in a row: &&&"",
""< is <, > is >, ' is ', etc."" handle numeric escapes, e.g.   – Jake Cobb Aug 3 '16 at 19:55 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}