re = /^\[(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}.\d[^+]+\+\d{2}:\d{2})\]\s(?<channel>[^.]+).(?<level>[^:]+):\s(?<body>.*)$/m
str = '[2024-04-27T03:36:48.026983+00:00] report.DEBUG: Hello World!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end