package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}.\d[^+]+\+\d{2}:\d{2})\]\s(?<channel>[^.]+).(?<level>[^:]+):\s(?<body>.*)$`)
var str = `[2024-04-27T03:36:48.026983+00:00] report.DEBUG: Hello World!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}