$re = '/^([3456]|\*)([\d\s]|[*\s])+$/';
$str = '4600303022022021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);