package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([3456]|\*)([\d\s]|[*\s])+$`)
var str = `4600303022022021`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}