re = /^\w+(?:\.\w+)+$/m
str = 'www.example.com
blog.example.com
shop.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end