$re = '/^\w+(?:\.\w+)+$/m';
$str = 'www.example.com
blog.example.com
shop.example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);