$re = '/(?i)(?<Lp>\d{1,2}(?![\s\S]*?(Lp\.|Ilość|Cena)))\s*(?<NazwaProduktu>([\S ]*?[\n\r]*){1,3})\s+(?<Ilosc>([a-z]{3}|\d{1,3}\s*[a-z]{3}))\s*(?<SWW>\s*\d{2}\.\d{2}\.\d{2}.\d{1,2})\s*(?<CenaNetto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<WartoscNetto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<StVAT>\d{1,2})\s*(?<KwotaVAT>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<WartoscBrutto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<Waluta>[a-z]{3})/m';
$str = 'aktura VAT
Oryginał
numer/data Data sprzedaży
904129299 / 05.06.2020 05.06.2020
Opracował Pani Tomasiuk /
+48 32 7375860/ monika.tomasiuk@hydac.com.pl
nr zamówienia Klienta/data T552744 / 25.03.2020 nr dokumentu dostawy/data sprzedaży 8113565910 / 05.06.2020 numer zamówienia/data 4276410 / 01.04.2020
numer Klienta / referencje Klienta 79004603
Wasz nr NIP
554-031-17-75
Nasz nr NIP
635-000-02-22
referencje płatności
0904129299
NABYWCA Pojazdy Szynowe PESA Bydgoszcz S.A.
Zygmunta Augusta 11
PL-85-082 BYDGOSZCZ
warunki płatności:
Do dnia 03.09.2020 po tym terminie naliczać będziemy ustawowe odsetki.
rodzaj wysyłki:
transport drogowy
warunki dostawy:
CPT Magazyn Odbiorcy
______________________________________________________________________________________________________
Lp. Nazwa towaru Ilość SWW/ Cena Wartość VAT Kwota Wartość
/PKWiU netto netto % VAT brutto
______________________________________________________________________________________________________
80 HRL 4 KP 28 PAFF CZARNE
Obejma numer art. Klienta 9461-3800-00-0309
PAR 25.11.10.0 3,75 150,00 23 34,50 184,50 PLN
______________________________________________________________________________________________________
Razem 150,00 34,50 184,50
______________________________________________________________________________________________________
Do zapłaty: 184,50 PLN
Słownie: STO OSIEMDZIESIĄT CZTERY 50/100 zł
Płatność prosimy dokonać na konto nr: 25 1750 1035 0000 0000 3761 9078
Do czasu uiszczenia całkowitej zapłaty, towar jest własnością sprzedającego.
Dokument wygenerowany elektronicznie, nie wymaga podpisu.
NABYWCA Pojazdy Szynowe PESA Bydgoszcz S.A.
Zygmunta Augusta 11
PL-85-082 BYDGOSZCZ
data/numer
05.06.2020 / 904129299
Strona
2 / 2
Joanna Korzeniec
.............................................
Podpis i pieczęć osoby uprawnionej do wystawienia faktury VAT
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);