#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?<Lp>\d{1,2}(?![\s\S]*?(Lp\.|Ilość|Cena)))\s*(?<NazwaProduktu>([\S ]*?[\n\r]*){1,3})\s+(?<Ilosc>([a-z]{3}|\d{1,3}\s*[a-z]{3}))\s*(?<SWW>\s*\d{2}\.\d{2}\.\d{2}.\d{1,2})\s*(?<CenaNetto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<WartoscNetto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<StVAT>\d{1,2})\s*(?<KwotaVAT>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<WartoscBrutto>(\d{1,3},\d{2}|\d{1,3}\.\d{1,3},\d{2}))\s*(?<Waluta>[a-z]{3})"
Local $sString = "aktura VAT" & @CRLF & _
"" & @CRLF & _
"Oryginał" & @CRLF & _
"numer/data Data sprzedaży" & @CRLF & _
"904129299 / 05.06.2020 05.06.2020" & @CRLF & _
"Opracował Pani Tomasiuk /" & @CRLF & _
"+48 32 7375860/ monika.tomasiuk@hydac.com.pl" & @CRLF & _
"nr zamówienia Klienta/data T552744 / 25.03.2020 nr dokumentu dostawy/data sprzedaży 8113565910 / 05.06.2020 numer zamówienia/data 4276410 / 01.04.2020" & @CRLF & _
"numer Klienta / referencje Klienta 79004603" & @CRLF & _
"Wasz nr NIP" & @CRLF & _
"554-031-17-75" & @CRLF & _
"Nasz nr NIP" & @CRLF & _
"635-000-02-22" & @CRLF & _
"referencje płatności" & @CRLF & _
"0904129299" & @CRLF & _
"" & @CRLF & _
"NABYWCA Pojazdy Szynowe PESA Bydgoszcz S.A." & @CRLF & _
"Zygmunta Augusta 11" & @CRLF & _
"PL-85-082 BYDGOSZCZ" & @CRLF & _
"warunki płatności:" & @CRLF & _
"Do dnia 03.09.2020 po tym terminie naliczać będziemy ustawowe odsetki." & @CRLF & _
"" & @CRLF & _
"rodzaj wysyłki:" & @CRLF & _
"transport drogowy" & @CRLF & _
"" & @CRLF & _
"warunki dostawy:" & @CRLF & _
"CPT Magazyn Odbiorcy" & @CRLF & _
"" & @CRLF & _
"______________________________________________________________________________________________________" & @CRLF & _
"Lp. Nazwa towaru Ilość SWW/ Cena Wartość VAT Kwota Wartość" & @CRLF & _
" /PKWiU netto netto % VAT brutto" & @CRLF & _
"______________________________________________________________________________________________________" & @CRLF & _
"80 HRL 4 KP 28 PAFF CZARNE" & @CRLF & _
"Obejma numer art. Klienta 9461-3800-00-0309" & @CRLF & _
"PAR 25.11.10.0 3,75 150,00 23 34,50 184,50 PLN" & @CRLF & _
"______________________________________________________________________________________________________" & @CRLF & _
" Razem 150,00 34,50 184,50" & @CRLF & _
"______________________________________________________________________________________________________" & @CRLF & _
" Do zapłaty: 184,50 PLN" & @CRLF & _
"Słownie: STO OSIEMDZIESIĄT CZTERY 50/100 zł" & @CRLF & _
"Płatność prosimy dokonać na konto nr: 25 1750 1035 0000 0000 3761 9078" & @CRLF & _
"Do czasu uiszczenia całkowitej zapłaty, towar jest własnością sprzedającego." & @CRLF & _
"Dokument wygenerowany elektronicznie, nie wymaga podpisu." & @CRLF & _
"NABYWCA Pojazdy Szynowe PESA Bydgoszcz S.A." & @CRLF & _
"Zygmunta Augusta 11" & @CRLF & _
"PL-85-082 BYDGOSZCZ" & @CRLF & _
"data/numer" & @CRLF & _
"05.06.2020 / 904129299" & @CRLF & _
"Strona" & @CRLF & _
"2 / 2" & @CRLF & _
"" & @CRLF & _
"Joanna Korzeniec" & @CRLF & _
"............................................." & @CRLF & _
"Podpis i pieczęć osoby uprawnionej do wystawienia faktury VAT" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")