re = /(?<identifiant>(?:[a-z0-9-_]+\.)*[a-z0-9]+)@(?<domaine>(?:[a-z0-9-_]+\.)*)(?<extension>[a-z]{2,6})/
str = 'test.test@test.test
toto@regex101.com
identifier@domain.subdomain.com
toto@do-main.gouv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end