const regex = /(?<identifiant>(?:[a-z0-9-_]+\.)*[a-z0-9]+)@(?<domaine>(?:[a-z0-9-_]+\.)*)(?<extension>[a-z]{2,6})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<identifiant>(?:[a-z0-9-_]+\\.)*[a-z0-9]+)@(?<domaine>(?:[a-z0-9-_]+\\.)*)(?<extension>[a-z]{2,6})', 'g')
const str = `test.test@test.test
toto@regex101.com
identifier@domain.subdomain.com
toto@do-main.gouv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}