$re = ';^http(s?)\:\/\/[^\s\/$.?#*]+\.[^\s\/$.?#*]+(\.[^\s\/$.?#*]+)*$;m';
$str = 'https://example.org
http://a.a
http://123.123.123.123:8074';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);