using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(s?)\:\/\/[^\s\/$.?#*]+\.[^\s\/$.?#*]+(\.[^\s\/$.?#*]+)*$";
string input = @"https://example.org
http://a.a
http://123.123.123.123:8074";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}