use strict;
my $str = '!function(){}() // test1
!function test2(){}() // test2
(function(){})() // test3
(function test4(){})() // test4
test5 = function(){} // test5
test6 = function _test6(){} // test6
let test7 = function(){} // test7
let test8 = function _test8(){} // test8
var test9 = function(){} // test8
var test10 = function _test10(){} // test10
myfunc(function(){}) // test11
myfunc(function test12(){}) // test12
let myobj = {test13 : function(){}} // test13
let myobj = {test14 : function _test14(){}} // test14
var myobj = {test15 : function(){}} // test15
var myobj = {test16 : function _test16(){}} // test16
';
my $regex = qr/(?:(?:(?:(?:var|let)[ \t]+)?([\w.\-]+)[ \t]*[:=]|[(!])[ \t]*)function(?:[ \t]+([\w.\-]+))?[ \t]*\([^)]*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}