const regex = /(?:(?:(?:(?:var|let)[ \t]+)?([\w.\-]+)[ \t]*[:=]|[(!])[ \t]*)function(?:[ \t]+([\w.\-]+))?[ \t]*\([^)]*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:(?:(?:var|let)[ \\t]+)?([\\w.\\-]+)[ \\t]*[:=]|[(!])[ \\t]*)function(?:[ \\t]+([\\w.\\-]+))?[ \\t]*\\([^)]*\\)', 'gm')
const str = `!function(){}() // test1
!function test2(){}() // test2
(function(){})() // test3
(function test4(){})() // test4
test5 = function(){} // test5
test6 = function _test6(){} // test6
let test7 = function(){} // test7
let test8 = function _test8(){} // test8
var test9 = function(){} // test8
var test10 = function _test10(){} // test10
myfunc(function(){}) // test11
myfunc(function test12(){}) // test12
let myobj = {test13 : function(){}} // test13
let myobj = {test14 : function _test14(){}} // test14
var myobj = {test15 : function(){}} // test15
var myobj = {test16 : function _test16(){}} // test16
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}