$re = '/^\d+(\.\d{1,5})?$/m';
$str = '425.23654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);