package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\.\d{1,5})?$`)
var str = `425.23654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}