re = /(?i)(?:^|\W)(credit)(?:$|\W)/m
str = 'Credit
CREDIT
credit
credits
invoice
credit note
sales credit
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end