import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:^|\\W)(credit)(?:$|\\W)";
final String string = "Credit\n"
+ "CREDIT\n"
+ "credit\n"
+ "credits\n"
+ "invoice\n"
+ "credit note\n"
+ "sales credit\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}