re = /\.*(?<sim1>[\w\.]{4,}).*[\s]TZ.*(?<simno>[\w\.])./m
str = ' [Vodacom TZ (SIM 2)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end