$re = '/\.*(?<sim1>[\w\.]{4,}).*[\s]TZ.*(?<simno>[\w\.])./m';
$str = ' [Vodacom TZ (SIM 2)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);