$re = '/(\(\d{2}\)\s)?\d+-?\d+/m';
$str = 'Tefones:
- (14) 91313-64
- 3333-55521';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);