package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\s([vc]\d.*)$`)
var str = `Kumo Desu ga, Nani ka? c311
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}