$re = '/.*\s([vc]\d.*)$/';
$str = 'Kumo Desu ga, Nani ka? c311
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);